I want two function names that do the same thing, allowing the user to use whichever they prefer.
For Vec a, i use "const" because a is never changed. Correct me if this is the wrong usage.
For int n in operator|, i do NOT use "const" because n is altered.
So my question is, should I use "const int n" in stack, because technically n doesn't change in stack, even though it changes in operator|.
Mat operator|( const Vec a, int n ){ // puts n horizontal a's next ontop of each other
Mat x;
for(; n>0; --n ) x.push_back(a);
return x;
} // so if n=0, we return an empty matrix
Mat stack( const Vec a, const int n ){ return a|n; }