Which would be considering a better coding style, this is for a merge sort in case you are wondering what I am doing with this line of code
int j = 0; // used to track for the temp array earlier in my code
// reset it to be reused as opposed to creating another int
for (int k = first; k < last; k++)
{
data[k] = merged[j];
j++;
}
//versus......
for (int k = first, int m = 0; k < last; k++, m++)
{
data[k] = merged[m];
m++;
}
just curious if it is bad coding style to have multiple declarations in my for loop.