While calling a member function from within another member function, isn't it better to write
this->member_fun( )
rather than
member_fun( ) ?
That would make it very clear that we are calling a member function.
What is the coding standard here? And what could be wrong with the first version?