I'm finishinh up my game for submission. Right now I'm doing the menus, and it's highly procedural, nasty long-winded chunks of code, as you can imagine..
And I'm trying to implement the following logic as part of a huge compound switch block:
If MENU_FLAG is STATUS, then display the status menu and the mission menu;
If MENU_FLAG is DEBRIEF, then display the debrief menu and the mission menu;
If MENU_FLAG is MISSION, then display the mission menu, but no other menu;
So if it was only one dependency then I could just remove a break from one of the switch cases, but because there are two it seems to me like the easiest and most elegant solution to just use a goto statement... I mean switch blocks are just glorified gotos anyway, right? Kinda?
So:
switch(MENU_FLAG)
{
case STATUS:
// Stuff
goto mission_menu:
case DEBRIEF:
// Stuff
// No break
case MISSION:
mission_menu:
// Stuff
break;
}
Is this an elegant way to solve a problem? Or is it bad programming? This project is 8000 lines of code so I don't want to taint it with bland unprofessionalism.. not until I get you guys' advice on it anyway :)
cheers